Jump to: navigation, search

Nexus Installation

Nexus Installation

The following guide assumes that you have already installed Mediawiki.

The Nexus master download includes four files, Nexus_wp.zip, Nexus_mw.zip, nexus4.wordpress.xml and NexusExtensions.zip.

Upload Nexus_mw.zip to the Mediawiki skins folder and unpack.

Add the following to LocalSetting.php

require_once( "$IP/skins/nexus/nexus.php" );
$wgDefaultSkin = "bootstrapnexus";

$wgRestrictDisplayTitle = false;
$wgAllowExternalImages = true;

The latter two settings are really a personal preference, the first gives you the option to hide the default page title by adding the following to the top of the page.

{{DISPLAYTITLE:<span style="display: none"></span>}}

The second setting simply lets you add a url link to an image. This is useful if you want to add the gallery or slideshow extension.


Introducing Nexus 4

Introducing Nexus 4

A WordPress Companion Skin for the Nexus 4 WordPress Theme.

Be sure to check out the guides pages as they differ from those of the WordPress theme, for example how links are applied to Mediawiki content

A WordPress Companion Skin for the Nexus 4 WordPress Theme.

Be sure to check out the guides pages as they differ from those of the WordPress theme, for example how links are applied to Mediawiki content

One unique system to meet all of your business needs.

Impliment the Nexus 4 Mediawiki Skin and WordPress theme to provide one seemless environment.

Explore Nexus 4 to see how it can benefit your business.

Check out the guides pages to see which amazing features are available or visit the support forums to ask questions.

Meeting all your Business Needs

The Nexus 4 system will be available to download once the Bootstrap 4 stable release is launched.

The Nexus 4 system offers unparalleled functionality, with WordPress providing the ability to blog, provide products and services with the free wooCommerce Plugin and client communication features with bbPress and/or BuddyPress, while the Nexus 4 Mediawiki Skin will meet your documentation needs.